Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста , составить программу,делящую положительное число на 2 и отрицательное число на 3(паскаль)

5-9 класс

Dubcova18121995 03 апр. 2017 г., 19:44:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shpilchenko77
03 апр. 2017 г., 21:40:33 (7 лет назад)

var
  x : real;
begin
  read (x);
  if x < 0 then x := x / 2 else x := x / 3;
  write (x);
end.

+ 0 -
Neochka
03 апр. 2017 г., 22:30:36 (7 лет назад)

begin, a=i, if (i>0) then..............

Ответить

Другие вопросы из категории

имеющийся у вас модем обеспечивает прием/передачу сообщений со скоростью 12 Кбит * с. Скорость передачи сообщений по телефонной линии – 23

Кбит * с. Пропускная способность системы равна:(Ответ 12 Кбит*сек)Нужно решение

Привет всем помогите решить 2 задачки по информатике.

они трудные,так что 30 баллов тому кто решит!

Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К

сожалению, проспать 14 часов ему не удалось, т.к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.
Входные данные: Два целых числа S и T(1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник.
Выходные данные: Целое число - через сколько часов зазвонит будильник.

Читайте также

ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции

деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.



Вы находитесь на странице вопроса "помогите пожалуйста , составить программу,делящую положительное число на 2 и отрицательное число на 3(паскаль)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.