Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача: Дано три вещественных массива. Определить в каком из них находится самый маленький элемент.

5-9 класс

Помогите найти ошибку или покажите решение, спасибо!

uses crt;
var a1:array [1..10] of real;a2:array [1..10] of real;a3:array [1..10] of real;
k1,k2,k3,i:byte;
function min(a:real):real;
var j:byte;
begin
for j:=2 to 10 do
if a[j]<min then min:=a[j];end;
begin clrscr;
for i:=1 to 10 do
read(a1[i]:3);writeln;
read(a2[i]:3);writeln;
read(a3[i]:3);writeln;
k1:=min(a1);k2:=min(a1);k3:=min(a1);
if (k1<k2) and (k1<k3) then writeln('В первом массиве');
if (k2<k1) and (k2<k3) then writeln('Во втором массиве');
if (k3<k1) and (k3<k2) then writeln('В третьем массиве');
readkey;
end.

Zimina2904 21 авг. 2015 г., 15:42:51 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Balhosha
21 авг. 2015 г., 17:11:10 (8 лет назад)

uses crt;
Const n=3;
var
A:array [1..n] of integer;
B:array [1..n] of real;
C:array [1..n] of real;
k1,k2,k3,i:integer;
function min(A1:real):real;
var j:integer;
begin
for j:=1 to n do
if A[j]<j then min:=A[j];
end;
begin clrscr;
for i:=1 to n do
Readln(A[i]);writeln;
Readln(B[i]);writeln;
Readln(C[i]);writeln;
k1:=min(A);
k2:=min(B);
k3:=min(C);
if (k1<k2) and (k1<k3) then writeln('Â ïåðâîì ìàññèâå');
if (k2<k1) and (k2<k3) then writeln('Âî âòîðîì ìàññèâå');
if (k3<k1) and (k3<k2) then writeln('Â òðåòüåì ìàññèâå');
readln;
end.

+ 0 -
Крисёнок
21 авг. 2015 г., 20:01:01 (8 лет назад)

Ошибок много, сейчас что-то решим

Ответить

Другие вопросы из категории

Помогите срочно пожалуйста!Переведите на язык логических выражений следующие высказывания:1) я поеду в Москву,и если встречу там друзей ,то мы

интересно проведем время.2)если будет солнечная погода,то ребята пойдут в лес,а если будет пасмурная погода,то ребята пойдут в кино.3) неверно,что если дует ветер,то солнце светит тогда,когда нет дождя.4) если урок информатики будет интересным,то никто из школьников -Миша,Вика,Света-не будет смотреть в окно

Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) Сумма цифр

трёхзначного числа х является чётным числом.

б) Треугольник со сторонами a, b, с являются равносторонним.

1.Три брата — Ваня, Саша, Коля — учились в разных классах одной школы. Ваня был не старше Коли, а Саша — не старше Вани. Назовите имена старшего из

братьев, среднего и младшего.

2. На спортивной площадке лесного городка спортсмены построились в следующем порядке: заяц, белка, волк, лиса, лось, медведь. Главный судья енот предложил всем построиться по росту, начиная с самого высокого: лось, медведь, волк, лиса, заяц, белка. Разрешалось перестраиваться в ряду, меняясь места­ми, только рядом стоящими парами и переходить на новое место, проходя также пару рядом стоящих зве­рей. За какое наименьшее число таких переходов мож­но перестроиться по росту?

Читайте также

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),

На столе лежит десять пронумерованных шляп. В каждой шляпе лежит по десять золотых монет. В одной из шляп находятся фальшивые монеты. Настоящая

весит 10 граммов, а поддельная только 9. В помощь даны весы со шкалой в граммах. Как определить в какой из шляп находятся фальшивые монеты, используя весы только для одного взвешивания? Весы могут взвешивать не более 750 грамм.

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

1.Дано трехзначное число. а)Определите, входят ли в него цифры 4 и 7. б)Определите, входят ли в него одновременно цифры 4 и 7. 2. Даны

четыре целых числа. Вывести на экран минимальное из них.

3.Даны три вещественных числа a, b и с - коэффициенты уравнения ax^2+bx+c. Найдите решение этого уравнения или сообщите, что решения не существует.



Вы находитесь на странице вопроса "Задача: Дано три вещественных массива. Определить в каком из них находится самый маленький элемент.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.