Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

с клавиатуры вводят слово и символ.Составте программу которая:подсчитывает количество вхождений заданного символа

10-11 класс

уаааз 22 июня 2013 г., 15:57:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Klon1979
22 июня 2013 г., 18:39:59 (10 лет назад)

var a:string; 

b:char;

i,sum:integer;

begin

readln(a,b);

for i:=1 to length(a) do begin

if pos(b,a)<>0 then begin

sum:=sum+1;

delete(a,1,pos(b,a));

end;

end;

writeln(sum);

end.

Ответить

Другие вопросы из категории

Сортировка массивов по возрастанию и по убыванию. Массив задается от

датчика случайных чисел random(). Сортировать один и тот же исходный
массив и по убыванию и по возрастанию значений элементов.

Читайте также

Решите пожалуйста,очень нужно! С клавиатуры вводят слово и символ. Составьте программу,которая:а)проверяет,есть ли в этом слове заданный

символ;б)определяет позицию заданного слова;в)подсчитывает количество вхождений заданного символа.



Вы находитесь на странице вопроса "с клавиатуры вводят слово и символ.Составте программу которая:подсчитывает количество вхождений заданного символа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.