Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Знайдіть помилку дуже прошу, програма для знаходження не найменшого і не найбільшого числа з трьох чисел

5-9 класс

program Project1;
var a,b,c:longint;
begin
readln(a,b,c);
if (a>b) and (a<c) or (a>c) and (a<b) then writeln(a);
if (b>a) and (b<c) or (b>c) and (b<a) then writeln(b);
if (c>b) and (a<b) or (c>a) and (b>c) then writeln(c);
writeln(maxlongint);
readln;
end.

Fnm76 16 февр. 2015 г., 0:01:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NakojAlis
16 февр. 2015 г., 2:43:52 (9 лет назад)

Ось:

program Project1; 
var   a,b,c:longint;
begin
readln(a,b,c);
if (a>b) and (a<c) or (a>c) and (a<b) then writeln(a) else
if (b>a) and (b<c) or (b>c) and (b<a) then writeln(b) else
if (c>b) and (a<b) or (c>a) and (b>c) then writeln(c);
readln;
end.

Не дуже розумію, навіщо ви написали рядок:"

+ 0 -
Katerishna83
16 февр. 2015 г., 5:03:06 (9 лет назад)

Задано три різних числа, модуль кожного з яких не перевищує 109. Визначте число, яке рівне одному із заданих чисел, але не є ні мінімальним, ні максимальним із них.

Вхідні дані:
Єдиний рядок вхідного файлу містить три заданих числа, записаних через один або кілька пробілів.

Вихідні дані:
Єдиний рядок має містити шукане число

+ 0 -
БРИКЕТ
16 февр. 2015 г., 7:08:41 (9 лет назад)

Вхідні дані Результат роботи
5 16 10


10

+ 0 -
Dens46RUS
16 февр. 2015 г., 9:37:41 (9 лет назад)

Зараз, зажди небагато...

+ 0 -
Shelest
16 февр. 2015 г., 11:18:11 (9 лет назад)

будьласка можете трішки бистріше ато мені вже йти треба

+ 0 -
Timka28
16 февр. 2015 г., 13:41:40 (9 лет назад)

пишу

Ответить

Другие вопросы из категории

Составить программу:

1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания
2. Задано четырехзначное число. Удалить из записи числа последнюю цифру. Определить, будет ли оставшееся число кратно 11

превратите одно слово в другое, всякий раз заменяя по 1букве так, чтобы новое слово было существительное в именительном падеже. пример: слоН-слоГ,

используйте подсказки.
паук
имени Горького
два
на машине
для грузоперевозок
ерунда
муха

1) Дано число n, n 100 . Создайте массив n×n и заполните его по следующему правилу:

- числа на диагонали, идущей из правого верхнего в левый нижний угол, равны 1;
- числа, стоящие выше этой диагонали, равны 0;
- числа, стоящие ниже этой диагонали, равны 2.

Читайте также

Помогите решить:

3. Знайдіть помилки у наведених фрагментах програми, запишіть фрагмент правильно, пояснивши суть помилки:

а) x:=1; a:=81;

for i:=1 downto 10 do

begin

x:=x*i;

a:=a+2*i;

end;

б) х:=1; y:=1;

repeat

y:=y*x+2;

x:=x-2

until x-12;

4. Визначте значення всіх змінних у результаті їх виконання.

а) x:=0; y:=1;

while y<4 do

begin

x:=x+y;

y:=y+1

end;

б) x:=0; i:=1;

repeat

i:=i+1;

x:=x+1/i;

until i>6;

5. Розробіть програму, яка виводитиме на екран значення квадратів та кубів натуральних чисел від 1 до n, де n>1 – натуральне число, значення якого задає користувач.

6. Розробіть програму, яка визначатиме суму парних чисел від 1 до 30.

Ребят, помогите с тестами! Буду благодарен!

1)Укажіть дії, які можна виконувати
для зміни структури таблиці MS Word:



Вы находитесь на странице вопроса "Знайдіть помилку дуже прошу, програма для знаходження не найменшого і не найбільшого числа з трьох чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.