Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны два числа m и n. Если m делится на n или n делится на m, выведите 1, а иначе —

5-9 класс

любое другое число.

Mordvinovvladi 10 мая 2013 г., 16:46:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Missisisabelle
10 мая 2013 г., 19:40:01 (10 лет назад)

я в паскале не силён, но если mod - это остаток от деления тоо

if(m mod n == 0 and(&&) n mod m = 0) то да

в синтаксисе ошибки наверное, подправь, но думаю идею ты понял

+ 0 -
ЮДН
10 мая 2013 г., 20:58:21 (10 лет назад)

Используя Writeln и Readln

+ 0 -
ToryScream
10 мая 2013 г., 21:50:24 (10 лет назад)

И еще Div и Mod

Ответить

Другие вопросы из категории

1) Нужно найти самое длинное слово в строке считая знаком их разделения пробел.

2) Составьте программу которая определяет количество буквы "а
" в заданном тексте.
3) Замените запятыми пробелы между словами заданного текста.

ПАСКАЛЬ

СРОЧНО ПОМОГИТЕ С ЛОГИЧЕСКОЙ ЗАДАЧЕЙ ПО ИНФОРМАТИКЕ, СРОЧНО ПОЖАЛУЙСТА...

"шестеро друзей в ожидании электрички заскочили в буфет в котором:
1)Маша купила себе тоже самое, что и Егор
2)Аня купила тоже, что Саша, но не стала покупать шоколадные печенье
3)Кирилл ел то же, что и Наташа,но кроме луковых чипов
4)Егора ел тоже, что и Наташа, но в место бутеров с котлетки предпочел картоф чипы
5)Саша ела тоже, что и Наташа, но вместо молочного коктейля, купила лимонад
Из чего состоялся завтрак каждого?

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений



Вы находитесь на странице вопроса "Даны два числа m и n. Если m делится на n или n делится на m, выведите 1, а иначе —", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.