Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Напишите код нахождения минимального элемента под не главной диагональю в квадратной матрице.

10-11 класс

Язык программирования Pascal/Basic .

Almaznu2005 20 дек. 2016 г., 10:39:12 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Диверсант
20 дек. 2016 г., 13:13:00 (7 лет назад)

Забавная задача.
Массив[1..10,1..10] из чисел 10..99(для удобства вывода).
Выводит:
Исходный массив,
Числа под побочной диагональю,
минимальное число под побочной диагональю.

program test;
uses crt;
const
  n=10;
var
  arr:array[1..10,1..10] of integer;
  i,j,min:integer;
begin
  randomize;
  clrscr;
  for i:=1 to n do
    begin
    for j:=1 to n do
      begin
      arr[i,j]:=random(90)+10;
      write(arr[i,j],' ');
      end;
    writeln;
    end;
 
  writeln;

 min:=arr[n-n+2,n];

  for i:=1 to n do
   begin
   for j:=1 to n do
     if i>n+1-j then
      begin
        if arr[i,j]<min then min:=arr[i,j];
        write(arr[i,j],' ');
      end
     else write('** ');
   writeln;
   end;
 writeln;
 writeln(min);
end.


Ответить

Другие вопросы из категории

Читайте также

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

HELP!HELP!

Составить программу по нахождению минимального элемента массива и определить его местонахождение в массиве.

ПОМОГИТЕ ПОЖАЛУЙСТА!!! СРОЧНО!!!

Составить программу, по нахождению минимального элемента в двойном массиве.

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали



Вы находитесь на странице вопроса "Напишите код нахождения минимального элемента под не главной диагональю в квадратной матрице.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.