Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ученик бежит по кругу. На старте стоит тренер и перед каждым новым кругом спрашивает ученика : "Пробежишь еще кружочек?" Подсчитать количество

10-11 класс

кругов

двоечница2 30 окт. 2013 г., 11:50:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dukal
30 окт. 2013 г., 12:34:41 (10 лет назад)

uses
  GraphABC;

var
  bool: string;
  circle: byte;

begin
  Line(window.Center.X, window.Center.Y, window.Width - 10, window.Center.Y);
  repeat
    circle += 1;
    writeln('Бежим...');
    for i: byte := 0 to 11 do
    begin
      arc(window.Center.X, window.Center.Y, circle * 2 + 20, i * 30, (i + 1) * 30);
      System.Threading.Thread.Sleep(20);
    end;
    writeln('Пробежишь ещё кружочек?');
    repeat
      readln(bool);
      if (bool in ['да', 'нет']) then
        break
      else
        writeln('Что?! Я не расслышал!');
    until (false);
  until (not (bool = 'да'));
  Writeln('Молодец! За столько кругов можно и на марафон... А пробежал ты... ', circle, '!');
end.

Ответить

Другие вопросы из категории

Прошу решить,заранее спасибо
№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Читайте также

Русский язык по цене 32р Английский язык по цене 27р 50 копеек Географию по цене на три рубля дороже учебника английского Алгебру по цене 1,5 раза дорож

е учебника по русскому языку.Найти и вывести на экран сумму денег Помогите пожалуйста

Помогите пожалуйста, очень надо :( "Расследование на диване" (по изображению - во влажениях) Итак, представьте: Вы

следователь-детектив. Наконец то вы ушли в отпуск и вы лежите на диване, читая книжку. Неожиданно раздался звонок в дверь. На пороге стояла взволнованная соседка. Оказалось, что она недавно нашла рисунок, на котором узнала своего сына. У сына есть друг Саша, который хорошо рисует, и она предполагает, что он нарисовал их отдых. Но женщина ничего не знала об этом событии, и очень просила вас помочь ей узнать как было дело. Взглянув на изображение (изображение во влажениях) вы смогли ответить на все ее вопросы:

1 . В какой день (число и месяц) начался этот отдых в лесу? 2. Сколько человек вместе с сыном жили в этом лагере? 3. На чем они приехали? 4. Какого числа был сделан рисунок? 5. В какое время суток был сделан рисунок? 6. Далеко ли от лагеря до ближайшего селения? 7. С какой стороны света дул ветер?

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен удвоенному числу, введенному с клавиатуры;
2-й равен квадрату предыдущего индекса;
3-й равен остатку от деления индекса на 2



Вы находитесь на странице вопроса "Ученик бежит по кругу. На старте стоит тренер и перед каждым новым кругом спрашивает ученика : "Пробежишь еще кружочек?" Подсчитать количество", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.