Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Переведите с basic'e на pascal: CLS

10-11 класс

FOR a = 1 TO 100

Nika351 04 авг. 2013 г., 11:34:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tigo1123
04 авг. 2013 г., 12:31:36 (10 лет назад)

Добавил ещё команду печати списка найденных троек, а не только их количества (строка   writeln('(',a,', ',b,', ',c,') '); ).


Program Vlad971997;
uses crt;
const n=100;
var
  a,b,c,count: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  count:=0;
  for a:=1 to n do
    for b:=1 to n do
      for c:=1 to n do
        if (a*a+b*b = c*c) and (a<b) then
          begin
            count:=count+1;
            writeln('(',a,', ',b,', ',c,') ');
          end;
  writeln('Всего найдено ',count,' пифагоровых троек');
end.

Ответить

Другие вопросы из категории

в магазине имеется 6 мониторов фирмы А, 7 мониторов фирмы В, 11 мониторов фирмы С и несколько мониторов фирмы D .Количество информации в сообщении "

куплен монитор фирмы D " равно 2 . Найдите количество мониторов фирмы D до покупки .
a) 1
b)2
c)8
d)16

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Код программы "Тест" на Pascal

Необходимо написать код программы в формате .txt , чтобы на экране выводилось следующее:

1. Выводится текст "Вам предлагается тест на тему "Поведение в кабинете информатики""

2. Выводится вопрос и несколько вариантов ответа.

3. Выводится "Выберите № ответа".

4. Вопросов всего 3.

5. Выводится "Тест окончен".

6. Выводится "Оценка: Зачет" или "Оценка: Незачет"

Вот сами вопросы:
1. На каком расстоянии от монитора должен
работать ученик за компьютером?

a) 15-20 см

b) 50-70 см

c) Меньше 40 см
d) 90-110 см
2. Можно ли класть тетради, книги, диски на
монитор и клавиатуру?

a) Можно.

b) Можно только на клавиатуру.

c) Можно только на монитор.

d) Нельзя.
3. При появлении запаха гари нужно…

a) Бежать за водой, чтобы предотвратить
дальнейшее возгорание.

b) Прекратить работу, сообщить
преподавателю
c) Не обращать внимания
d) Быстро убежать из кабинета

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Пожалуйста напишите программу на pascal.

Вывести все четырехзначные, у которых все цыфры разные, кратные К и произведение цифр которых равно числу N.



Вы находитесь на странице вопроса "Переведите с basic'e на pascal: CLS", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.