Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

. Выведите все N-значные числа, которые не содержат цифру D, в

5-9 класс

возрастающем порядке.

Sunkarpro 02 апр. 2014 г., 16:59:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ашарша
02 апр. 2014 г., 18:43:36 (10 лет назад)

uses crt;
var n,d,z,x,c,k,a,b:integer;
begin
     write('N:'); readln(n);
     write('D:'); readln(d);
     a:=round(power(10,n-1));
     b:=round(power(10,n)-1);
     for x:=a to b do
     begin
          z:=x;
          k:=0;
          while z>0 do
          begin
               c:=z mod 10;
               if c=d then inc(k);
               z:=z div 10;
          end;
          if  k=0 then writeln(x,' ');
     end;
end.

Ответить

Другие вопросы из категории

Расшифруйте текст, записанный шестнадцатеричным кодом, если известно, что код 98 соответствует букве «Й»: А6 97 9Е А0 АА. Не забудьте, что при

кодировании символов используется принцип «последовательности», а буквы «ё» и «Ё», как правило, кодируются вне алфавита.

пользователь работал с каталогом C / Документы / Договора / Продажа / . Сначала он поднялся на один уровень вверх затем спустился в каталог Срочные затем

спустился в каталог Покупка. Запишите полный путь каталога в котором оказался пользователь 1) C: / Срочные/Покупка 3)C:/Документы /Срочные /Покупка/Продажа 2)C:/Документы/ Срочные / Покупка 4)C /Документы /Договора/Срочные/Покупка

Задумайте произвольное число. С помощью Калькулятора выполните следующую цепочку преобразований: • прибавьте к задуманному числу 25;

• к ответу прибавьте еще 125;
• из ответа вычтите 36;
• из ответа вычтите задуманное число;
• ответ умножьте на 5;
• ответ разделите на 2.

У вас должно получиться число 285. Объясните, почему у всех получился один и тот же ответ, хотя исходные числа были различными.

Найти площадь боковой поверхности цилиндра, известно радиус и

высота. (примерное оформление на фото)

Читайте также

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Дано натуральное число n. Определить является ли оно простым или составным. Простым называется число, которое не имеет делителей кроме 1 и самого себя.

Например, 17 и 43 - простые числа.Для решения задачи приведена программа с пропущенными строками. Необходимо в ответе записать содержание пустых строк, которое сделает программу правильной. Количество и расположение строк не менять.
Program Task;
Uses CRT;
Var n,i:integer;
b:boolean;
Begin
repeat
write('Число='); readln(n);
until n>0;
b:=true;
пропущена строка надо чтото записать
repeat
снова пропущена строка и надо что то записать
i:=i+1

Решите пожалуйста! 1. С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5. Подсчитать количество и сумму тех, которые

больше 10.
2. Напечатать все делители заданного числа.

Это циклы,ршите в паскале!



Вы находитесь на странице вопроса ". Выведите все N-значные числа, которые не содержат цифру D, в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.