Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Всем Привет!1. В текстовом файле хранятся квадратные целочисленные матрицы

10-11 класс

порядка n. Преобразовать
файл, удалив из каждой матрицы элементы побочной диагонали.

Nika01396 04 февр. 2014 г., 12:55:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annakka
04 февр. 2014 г., 14:36:59 (10 лет назад)

const
  n = 3;

type
  M = array[1..3, 1..3] of integer;

var
  i, j: integer;
  f: Text;
  a, b: M;
  s:string;

begin
  Assign(f, 'input.dat');
  Reset(f);
  writeln('Считываемые данные');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      read(f, a[i, j]);
      write(a[i, j]:4)
    end;
    writeln
  end;
  writeln;
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      read(f, b[i, j]);
      write(b[i, j]:4)
    end;
    writeln
  end;
  Close(f);
  Rewrite(f);
  for i := 1 to n do
    for j := 1 to n do
      if j <> n + 1 - i then
        write(f, a[i, j], ' ');
  writeln(f);
  for i := 1 to n do
    for j := 1 to n do
      if j <> n + 1 - i then
        write(f, b[i, j], ' ');
  writeln(f);
  Close(f);
  Reset(f);
  writeln('Данные, перезаписанные в файл');
  while not eof(f) do
    begin
    readln(f,s);
    writeln(s)
    end;
  Close(f);
  writeln
end.

Тестовое решение:

Считываемые данные
   2   3   7
   4   3   1
   8   9   6

  14   3  12
   5  -2   8
   6   0  13
Данные, перезаписанные в файл
2 3 4 1 9 6
14 3 5 8 0 13


+ 0 -
Riddlelady777
04 февр. 2014 г., 17:02:55 (10 лет назад)

Решить нужно на языке Паскаль

+ 0 -
RoadToHeaven
04 февр. 2014 г., 17:52:04 (10 лет назад)

Комментарий удален

+ 0 -
Vlada1337383828
04 февр. 2014 г., 18:37:06 (10 лет назад)

Комментарий удален

+ 0 -
Formatix111
04 февр. 2014 г., 20:36:03 (10 лет назад)

может быть обнулить элементы диагонали и сместить их в конец каждой строки и вывести без них матрицу. А просто удалить, если массив не строковый не получится

+ 0 -
Elmira0297
04 февр. 2014 г., 22:06:23 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

Построить диаграмму для данного распределения.

Распределение жилого фонда городского района по типу квартир
№ п./п. Группы квартир по числу комнат Число квартир, (тыс. ед.)
1. Одно 10
2. Двух 35
3. Трех 30
4. Четырех 15
5. Пяти 5
Всего 95



нужно составить программу в паскале по алгаритму

начало
ввод A,B,C
A>B
да нет
A>C B>C
да нет да нет
D:=A D:=C D:=B D:=C
вывод D
конец

Опишите, какие действия с информацией (информационные процессы) будут выполнены учеником, если он: а) учит правило - запись информации

в память

б) решает у доски задачу -

в) слушает музыку;

г) пишет письмо;

д) переводит текст с английского языка на русский;

е) пишет диктант.

помогите пожалуйста:

Напиши цифровой фильтр. На вход программе подаётся строка символов. На выходе должны быть только её цифры. Например, если на входе была строка
He110, k177en!
то на выходе должно быть
110177

2. В строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. Например, если на вход программе подавалась строка
Меня истина манит сияньем
то на выходе будет
истина

На вход подаётся строка. Вывести часть входной часть строки. Часть строки задаётся номером первого символа и количеством символов.

var
s: string;
n, k, i: integer;
Begin
readLn(s, n, k);
for i := n to n+k-1 do write(s[i]);
End.


2. На вход подаётся предложение на английском языке. Вывести все гласные строки в том порядке, в котором они встречались в строке.


(ключевой фрагмент)
for i := 1 to length(s) do
if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
then write(s[i]);


Варианты программы определения, является ли строка полиндромом
--------------------------------------------------------------
var
s, s1: string;
i: integer;
Begin
readLn(s);
s1 := '';
for i := 1 to length(s) do s1 := s[i] + s1;

write('строка ');
if s1 <> s then write('не ');
writeLn('является полиндромом');
End.



var
s: string;
i, j: integer;
Begin
readLn(s);

i := 1;
j := length(s);
while (i < j) and (s[i] = s[j]) do begin
inc(i);
dec(j);
end;
write('строка ');
if s[i] <> s[j] then write('не ');
writeLn('является полиндромом');
End.


Читайте также

Всем Привет! Люди добрые помогите решением. Первую задачу отправил на проверку Спасибо!!! Сейчас вторая. В матрице A(m x m) найти сумму элементов

четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В противном случае ко всем элементам побочной диагонали прибавить число 2.

10-11 класс информатика ответов нет
составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная

матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.

Всем привет. У меня такая проблема. Мне по информатики задали снять фильм, не могли бы вы подсказать мне книгу, которую я могла бы взять в основе сюжета. Н

о главное, книга должна быть очень интересной, желательно малоизвестной и не большой.
Так же можете кинуть идею сами. Жанр, стиль и т.д. не ограничен. Спасибо всем. P. S. : Я конечно придумала сюжет сама, но хочется послушать еще варианты, вдруг будет что-то интереснее.

1) Скорость передачи данных через ADSL-соединение равна 1024000 бит/c. Передача файла через данное соединение заняла 5 секунд. Определите размер файла

в килобайтах.

2) Скорость передачи данных через ADSL-соединение равна 256000 бит/c. Передача файла через это соединение заняла 2 минуты. Определите размер файла в килобайтах.

3) Сколько секунд потребуется обычному модему, передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640х480 пикселей, при условии, что цвет каждого пикселя кодируется тремя байтами?

4) Скорость передачи данных через модемное соединение равна 51 200 бит/с. Передача текстового файла через это соединение заняла 10 с. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

5) Скорость передачи данных через ADSL-соединение равна 128000 бит/с. Передача текстового файла через это соединение заняла 1 минуту. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

6) Информационное сообщение объемом 2.5 Кбайт передается со скоростью 2560 бит/мин. За сколько минут будет передано данное сообщение?



Вы находитесь на странице вопроса "Всем Привет!1. В текстовом файле хранятся квадратные целочисленные матрицы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.