Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

перевести числа из 10-ную системы счисления в 2-ную и 8-ную системы счисления 52

10-11 класс

Викуся123456 16 янв. 2015 г., 5:49:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hgkjdtjtu
16 янв. 2015 г., 7:58:07 (9 лет назад)

52 (в десятичной системе счисления)
52/2=26
26/2=13
13/2=6 (1 в остатке) 
6/2=3
3/2=1 (1 в остатке) 
Следовательно 52 в двоичной системе счисления - 10100

52(в десятичной системе счисления)
52/8=6 (4 в остатке)
6/8 (нацело не делится, 6 в остатке) 
Следовательно, 52 в восьмеричной системе - 64

Ответить

Другие вопросы из категории

Как заменить программму в турбо паскале чтоб она решалась в паскале ABC? program kRUGI;

uses crt;
var gd,gm,c,i,r,x,y,n:integer;
begin
clrscr;
randomize;
writeln('введите колличество окружностей->');
readln(n);
gd:=0;
for i:=1 to n do begin
r:=random(80);x:=random(600);y:=random(400);
c:=random(15);setcolor(c);
circle(x,y,r);
setfillstyler(1,c);floodfill(x,y,c);
end;
readkey;
closegraph;
end.

Вычислите значения выражений:

а)  256_{8}+ 10110,1_{2}*( 60_{8}+ 12_{10})-1 F_{16}
б) 1 AD_{16}- 100101100 _{2} : 1010_{2}+ 217_{8}
в)  1010_{10} + ( 106_{16} - 11011101_{2} )* 12_{8}
г)  1011_{2} * 1100_{2} : 14_{8} + ( 100000_{2} - 40_{8})
С решением пожалуйста. Ответы запишите в десятичной системе.

Помогите решить на с++ или pascale срочно

Таймер - это часы, которые умеют подавать звуковой сигнал по прошествии некоторого периода времени. Напишите программу, которая определяет, когда должен быть подан звуковой сигнал.Входные данныеВ первой строке входного файла INPUT.TXT записано текущее время в формате ЧЧ:ММ:СС (с ведущими нулями). При этом оно удовлетворяет ограничениям: ЧЧ - от 00 до 23, ММ и СС - от 00 до 60.Во второй строке записан интервал времени, который должен быть измерен. Интервал записывается в формате Ч:М:С (где Ч, М и С - от 0 до 109, без ведущих нулей). Дополнительно если Ч=0 (или Ч=0 и М=0), то они могут быть опущены. Например, 100:60 на самом деле означает 100 минут 60 секунд, что то же самое, что 101:0 или 1:41:0. А 42 обозначает 42 секунды. 100:100:100 - 100 часов, 100 минут, 100 секунд, что то же самое, что 101:41:40.

Запишите в виде логической формулы следующие высказывания:

Если Иванов здоров и богат, то он здоров.
Число является простым, если оно делится только на единицу и само на себя.
Если число делится на 4, то оно делится и на 2.
Произвольно взятое число либо делится на 2, либо делится на 3.
Спортсмен подлежит дисквалификации, если он некорректно ведет себя по отношению к сопернику или судье, и если он принимал “допинг”.

Читайте также

20,9- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления. Выполнить в этих системах их сложение, вычитание и умножение. Ответ записать в 10-ой

системе счисления.

80,1- Перевести их в 2-ую, 8-ую и 16-ую, системы счисления.

Выполнить в этих системах их сложение, вычитание и умножение.

Ответ записать в 10-ой системе счисления.

1)перевести число 17 в двоичную систему счисления

2) перевести число 10011 из двоичной системы счисления в десятичную

СРОЧНО! ПОМОГИ! ПОЖАЛУЙСТА!!!!!! №1. В системе счисления с некоторым основанием десятичное число 43 записывается в виде «111». Укажите это

основание

№2. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 53 оканчивается на 3.

№3. Укажите через запятую в порядке возрастания все числа, не превосходящие 30, запись которых в двоичной системе счисления оканчивается на «101». Числа в ответе указывайте в десятичной системе счисления.

№4. Количество единиц в двоичной записи числа 12, 25 равно…

№5. Для кодирования букв А,Б,В,Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким образом закодировать последовательность символов ГБАВ и перевести результат в шестнадцатеричную систему счисления, то получится…

№6. Как представляется десятичное число 13,5 в двоичной системе счисления?

№7. Как представляется десятичное число 416 в восьмеричной системе счисления?

№8. Как представляется десятичное число 523 в шестнадцатеричной системе счисления?

№9. Вычислите значение суммы 1012 + 118 + 1016. Результат представьте в виде десятичного числа.

№10. Вычислите значение разности двух чисел 1116 – 118. Результат представьте в виде десятичного числа.

Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. Определите

максимальное из таких чисел, записанное в системе счисления по основанию 16.

Сколько существует различных пар натуральных чисел, таких что: 1. Оба числа, записанные в семеричной системе счисления, имеют ровно по три значащих

разряда. 2. Сумма этих чисел, записанная в семеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.



Вы находитесь на странице вопроса "перевести числа из 10-ную системы счисления в 2-ную и 8-ную системы счисления 52", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.