Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Program Pr1;

5-9 класс

uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v 1;
end
else if i mod 2<>0 then v:=v 1;
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.

ребят в этом алгоритме есть ошибка найдите её плз

87ri 02 сент. 2013 г., 15:43:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Miheeva23
02 сент. 2013 г., 17:16:59 (10 лет назад)

Program Pr1;
uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v{?} 1; {здесь либо пропущен знак либо v1-новая переменная не перечисленная в списке описания переменных}
end
else if i mod 2<>0 then v:=v 1;{здесь тоже самое}
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.

Ответить

Другие вопросы из категории

РЕБЯТ,СРОЧНО!

Напишите программу для робота(КуМир),чтобы на втором квадратике(картинке) все клетки были закрашены.С ПОВТОРОМ(ну вначале нц,потом сколько раз и кц)

Приведите примеры:

А) неформальных исполнителей
Б)формальных исполнителей

Читайте также

Program tutor;

var
x: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Writeln(x);
end.

Что в этой программе не так? Я хочу извлечь корень из х, а программа пишет "ОШИБОЧНЫЙ ИДЕНТИФИКАТОР".

Program tutor;
var
X, Z: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Z:=sqrt(X);
Writeln(x,z);
end.

И через "sqrt"- оператор не хочет выдавать корень из Х. Что я не так делаю? подскажите.

Прошу вас, помогите! Решается оценка!!! Найдите ошибки в программе 1)Program z1; var a:integer; begin a:=10; while

a<5 do

writeln(a);

a:=a+1;

End.

2)Program z2;

var a,s:integer;

begin

a:=1; s:=0;

while a<10 do begin

s:=s+a/2;

end;

writeln(s);

end.

Помогите пожалуйстаа!! Определите результат работы программы, написанной на языке Паскаль. 1) program a5 var i, m:

integer;

begin

m:= 0

for i: = 1 to 6 do

m: = m-6

writeln (m)

end.

2) program a6

var i, m: integer;

begin

m:= 0;

for i: = 3 to 7 do

m: = m-6+i;

writeln (m)

end.



Вы находитесь на странице вопроса "Program Pr1;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.