Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найдытее минимальный элемент и его индекс в массиве паскаль

5-9 класс

ЭмиКо 05 июля 2015 г., 22:35:07 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastic16
06 июля 2015 г., 0:20:07 (8 лет назад)

procedure MinElem(a: array of integer; var min: integer; var minind: integer);
begin
min := a[0];
minind := 0;
for var i:=1 to a.Length-1 do
if a[i]<min then
begin
min := a[i];
minind := i;
end;
end;

Ответить

Другие вопросы из категории

Помогите пожалуйста сделать номер по инф

Номер 143 надо сделать : определить , что получится в результате выполнения в графическом редакторе следущей последовательности действий :

Ном

Дана программа:

Var a,b,x:integer;BeginWrite('введите два числа ');Readln(a,b);X:=a mod b;Writeln('ответ-',x);End.

Помогите решить задачу в программе Turbo Pascal. Ели вас это не затруднит, то напишите решение:)) Заранее большое спасибо:) 1)Даны две переменные

целого типа А и В. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным 0 значений. Вывести новые значения переменных А и В. 2) Даны длина и высота форточки. Определите, влезет ли голова в форточку с радиусом R.

Читайте также

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

составьте программу,которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10,затем элементы с четными индексами удваивает, а

элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массивы.



Вы находитесь на странице вопроса "Найдытее минимальный элемент и его индекс в массиве паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.