Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти наибольшее из четырёх чисел.

10-11 класс

На C++

Melissaspb 07 марта 2015 г., 11:03:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vyglovskaya2015
07 марта 2015 г., 13:06:39 (9 лет назад)

#include <stdio.h>

main()
{
int a,b,c,d;
scanf("%d%d%d%d",&a,&b,&c,&d);
if(a>=b)
if(a>=c)
if(a>=d)
printf("%d",a);
else printf("%d",d);
else {if(c>=d) printf("%d",c); else printf("%d",d);}
else if(b>=c) if(b>=d) printf("%d",b);
else printf("%d",d);
else if(c>=d) printf("%d",c);
else printf("%d",d);
}







+ 0 -
мартинастоссель
07 марта 2015 г., 14:26:01 (9 лет назад)

а почему не на pascal например

+ 0 -
гравитационная
07 марта 2015 г., 16:50:52 (9 лет назад)

А на pascal я уже сделал. Теперь нужно на C++.

Ответить

Другие вопросы из категории

Возникла очень интересная проблемка. В общем, мы сейчас проходим MS FrontPage, и на самом уроке столкнулись с проблемой, решение которой не знает даже

учители. В общем, при вставке двух jpg - изображений, в самой программе они видны, то есть их можно растягивать, перемещать и т.д.. Но когда мы сохраняем их уже в html формате и запускаем в explorer, то видно только одно изображение, второе просто белое и с значком "крестика", то бишь его якобы можно закрыть. Все ресурся находятся в школе, так что скинуть сюда не смогу. Подскажите, какие факторы влияют на это, при том, что оба изображения в одном формате, но разного размера.

помогите решить срочно надо
Переведите из десятичной системы счисления в указанные системы счисления

1739(10)->х(16)
199(10)->х(8)
155(10)->х(2)
201(10)->х(5)

Читайте также

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B



Вы находитесь на странице вопроса "Найти наибольшее из четырёх чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.