Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решите 2 задачи в Паскале! Плииз! 1) Вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 дают в остатке 4, и их

10-11 класс

колличество. Конец программы:

SumChis :=0;

for i:1 to 100

if i mod 6 = 4 then

begin

writeln (i);

SumChis :=SumChis +1;

end.

Написать надо начало программы!

2) Написать программу, которая выводит натуральные числа до 10 000 включительно, которые при делении на 17 дают остаток 11 или B

Essu34vd 21 апр. 2016 г., 2:44:48 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zaktarenkoa
21 апр. 2016 г., 3:15:42 (8 лет назад)

1)

var sumchis, i:integer;

begin

for i:=1 to 100 do begin

if i mod 6 =4 then

begin

writeln(i);

sumchis:=sumchis+1;

end;

end;

writeln('Колличество чисел', sumchis);

end.

 

2)

var sumchis, i:integer;

begin

for i:=1 to 10000 do begin

if i mod 17 =11 then

begin

writeln(i);

sumchis:=sumchis+1;

end;

end;

writeln('Колличество чисел', sumchis);

end.

 

Как сделать чтобы остаток равнялся B - не знаю, так как программа начинает считывать её как за переменную, если только B определить как переменную и в неё внести значение какое-то.

 

 

Ответить

Другие вопросы из категории

Помогите решить, будьте добры

Ответ равен 65536. Объясните решение.

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.

Решите задачу в Паскале. Если можно с блок - схемой.

Дана последовательность чисел. Вывести на экран все отрицательные числа.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива



Вы находитесь на странице вопроса "Решите 2 задачи в Паскале! Плииз! 1) Вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 дают в остатке 4, и их", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.