Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Для

10-11 класс

матрицы размером в n строк и m
столбцов составить алгоритм и программу вычисления:

супер2345 26 июля 2014 г., 13:56:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
коляникита
26 июля 2014 г., 16:22:32 (9 лет назад)

1)
program cgt;
var a:array[1..100,1..100]of integer;
s,n,m,i,j:integer;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
for j:=1 to m do
if(i mod 2=1)then s:=s+a[i,j];
end;
writeln(s);
end.
2)
program cgt;
var a:array[1..100,1..100]of integer;
n,m,i,j:integer;
s,p:real;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
p:=1;
if(i mod 2=0)then begin
for j:=1 to m do
begin
p:=p*(sin(a[i,j]*pi/180))/(cos(a[i,j]*pi/180));
end;
s:=s+p;
end;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Выпишите целые числа, принадлежащие следующим числовым промежуткам: а) (101101(2);110000 (2)) в двоичной системе

б) (14 (8);20(8)) в восьмеричной системе
в) (28(16);30(16)) в шестнадцатеричной системе
Ответ для каждого числа запишите в указанной и десятичной системах счисления.

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Вам необходимо преобразовать множество старых программ для новой версии компилятора. Для этого необходимо заменить "->" на "." везде, кроме

комментариев. Комментарии в данном языке программирования начинаются с символов "//" и продолжаются до конца строки. Напишите программу, выполняющую такое преобразование. Входной файл содержит от 1 до 500 строк длиной не более 50 символов с ASCII-кодами от 32 до 127 – текст программы, которую нужно преобразовать. В выходной файл вывести преобразованный текст программы.

Пример ввода

Test* t = new Test(); t->a = 1; t->b = 2; t->go(); // a=1, b=2 -> a=2, b=3

Вывод для примера

Test* t = new Test(); t.a = 1; t.b = 2; t.go(); // a=1, b=2 -> a=2, b=3

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500



Вы находитесь на странице вопроса "Для", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.