Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

в линейном массиве вещественных чисел а (n) заменить все элементы большие 10. на число с.

10-11 класс

Bagyra 09 авг. 2014 г., 17:31:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bazzzinga
09 авг. 2014 г., 20:16:43 (9 лет назад)

const
  k = 20;

var
  a: array[1..k] of integer;
  c, i, n: integer;

begin
  Randomize;
  write('Введите число элементов массива (не более 20): ');
  readln(n);
  write('Введите целое число С: ');
  readln(c);
  write('Исходный массив: ');
  for i := 1 to n do
  begin
    a[i] := Random(41) - 20;
    write(a[i], ' ')
  end;
  write(#13#10,'Массив-результат: ');
  for i := 1 to n do
  begin
    if a[i] > 10 then a[i] := c;
    write(a[i], ' ')
  end
end.

Тестовое решение:

Введите число элементов массива (не более 20): 18
Введите целое число С: 99
Исходный массив: -1 -17 -15 16 12 -12 14 19 -1 18 13 11 -17 -6 -17 -2 20 -14
Массив-результат: -1 -17 -15 99 99 -12 99 99 -1 99 99 99 -17 -6 -17 -2 99 -14


Ответить

Другие вопросы из категории

Для

матрицы размером в n строк и m
столбцов составить алгоритм и программу вычисления:

Выпишите целые числа, принадлежащие следующим числовым промежуткам: а) (101101(2);110000 (2)) в двоичной системе

б) (14 (8);20(8)) в восьмеричной системе
в) (28(16);30(16)) в шестнадцатеричной системе
Ответ для каждого числа запишите в указанной и десятичной системах счисления.

Читайте также

Cрочно! Язык visual basic,массивы - задачи:

1)Заменить значение любого элемента массива на а
2)Определить имеются ли четные числа в массиве
3)Заменить все элементы некоторой строки на заданное число
4)Вывести все элементы N столбца и M строки

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

на минимальный. Выведите на экран исходный и полученный массивы.



Вы находитесь на странице вопроса "в линейном массиве вещественных чисел а (n) заменить все элементы большие 10. на число с.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.