Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

как пройти уровень в час кода ам ням 8 уровень

5-9 класс

Stolyarchuksve 26 окт. 2016 г., 16:59:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ritari
26 окт. 2016 г., 19:47:29 (7 лет назад)

Очень просто. В цикл вставляешь два условия, и шагаешь

Ответить

Другие вопросы из категории

помогите найти ошибку!!! 1. "Дано число, определить количество четных цифр." Program task3; var a, ost, k: integer;

begin
write ('Ввести число a ->'); read (a);
k:=0;
while a<>0 do begin
ost:= a mod 10;
if ost div 2 = 0 then k:=k+1;
end;
writeln (k);
end.

2. "Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали в дневник температуру. Найти среднюю температуру для дней с температурой выше 0 градусов. Определите количество дней. Программа получает на выход количество дней, в течении которых проводится наблюдение."

Program task4;

var a, s, t, y, k: integer; n: real;
begin
write ('Введи количество дней ->');
read (a);
k:=1;
s:=0;
t:=y;
repeat
write ('Введи температуру в ',k,'-ый день');
read (y);
if a>31 then write ('Количество дней в месяце меньше 31');
if t>0 then k:=k+1;
if t>0 then s:=s+t;
if t=y then write ('k=',k); write ('s=',s);
until t=y;
if t=y then n:=s/k;
writeln ('n=',n);
end.

Читайте также



Вы находитесь на странице вопроса "как пройти уровень в час кода ам ням 8 уровень", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.