Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти значение d в этих 2-х задачах d=0 If i:=1 to 4 do i<then d:=d+i else d:=d+1 ( это в паскале) d=0 if i:=1to4 do if i<3 then d:=2 else

10-11 класс

d:=d+1

Tanakysay 06 янв. 2016 г., 19:36:27 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mishawolk
06 янв. 2016 г., 22:14:58 (8 лет назад)

неправильное условие 1 to 4 это цикл for а у тут if(условие) проверьте правильность задачи

возможно так:

d:=0;

for i:=1 to 4 do

if i<3 then d:=2;

else d:=d+1;


в таком случае d=2

Ответить

Другие вопросы из категории

1.Напиши

программу , которая присваивает переменной х значение 9, а затем выводит на
экран: в первой строке это значение с поясняющей надписью (например значение
х равно 9), а во второй – квадрат этого значения (тоже – с поясняющей
надписью).

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив. Задание 1.

Заполнить двухмерный массив ABCD [1..5,1..5] константами:


1 4 7 -10 13
7 10 13 15 19
13 -16 19 22 25
19 22 25 -28 31
25 28 31 34 37

а) Удвоить все элементы массива, которые > 3.
б) Найти сумму всех элементов полученного массива.
в) Вывести на экран исходный и полученный массив.

Задача 1. Информационные объем одного символа некоторого сообщения равен 6 битам. Сколько символов входит в алфавит, с помощью которого было составлено

это сообщение?
Задача 2. Информационное сообщение имеет объем 3 Кбайта. Сколько в нем символов, если размер алфавита, с помощью которого оно было составлено, равен 16?

Читайте также

ХОТЯ БЫ ОБЪЯСНИТЕ КАК РЕШИТЬ! ОЧЕНЬ НАДО! НУ ВСЕ ПУНКТЫ ЧТО ЕСТЬ ОТДАЮЮЮЮЮ Тело брошено

вертикально вверх со скоростью 40 км/ч. Найти значение проекции скорости этого тела в течении 6 секунд, через каждые 0,5 секунд


Надо решить в электронной таблице HELP PLEASE!

Для некоторых это будет легко,но для меня трудно.У меня идеи есть,но до сих пор не получается реализовать,чтобы все работало.

Я прошу помочь с выполнением задачи.
Напишите пожалуйста код в C++, который делает следующее:
Найти номер элемента массива,модуль разности сумм чисел слева и справа от которого наименьший.Значение элемента с этим номером при суммировании не учитывается.Номера элементов начинаются с 0.
Допустим элементы последовательности такие : 1,2,3,4,5,6,2.
Ответ:номер элемента 4.,т.е. это число 5 последовательности.
Помогите пожалуйста написать код.

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Попробуйте внести изменения в блок-схему на рисунке так,чтобы алгоритм учитывал возможность выбора нескольких элементов набора

данных,удовлетворяющих одному и тому же значению критерия поиска.Например позволял решить задачу поиска из задания 3(В журнале успеваемости учащихся со сведениями о годовых оценках требуется осуществить поиск всех отличников по информатике. Что в этой ситуации является набором данных, что- ключом поиска, что- критерием поиска?)Задание 3 не нужно делать.Но нужно главное внести изменения в схему



Вы находитесь на странице вопроса "Найти значение d в этих 2-х задачах d=0 If i:=1 to 4 do i&lt;then d:=d+i else d:=d+1 ( это в паскале) d=0 if i:=1to4 do if i&lt;3 then d:=2 else", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.