Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Срочно написать программу в паскале!

10-11 класс

Упорядочить массив в интервале от i1 до i2 по убыванию

Slavikfifa14 09 апр. 2015 г., 19:04:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
агю
09 апр. 2015 г., 19:35:22 (9 лет назад)

Sub test()
'массив и диапазон для примера
m = Array(0, 1, 2, 3, 4, 5, 6, 7, 8, 9)
i1 = 2 'с 3-го злемента (0,1,2)
i2 = 7 'по восьмой
'собственно, сам алгоритм
For x = i1 To i2 - 1
For y = x + 1 To i2
If m(x) < m(y) Then tmp = m(x): m(x) = m(y): m(y) = tmp
Next y, x
MsgBox Join(m, ";") 'это просто проверка
End Sub
Надеюсь помог

Ответить

Другие вопросы из категории

Дан фрагмент ЭТ. Какое значение будет в ячейке D1? А В

С

D

1

3

5

4

=ЕСЛИ(ИЛИ(И($С$ 1 >=А1; $C$K=B1);ABS(B1-$C$1)=1); А1+В1; В1-$С$1)

1)8 3)2

2)1 4)9

Приведите два примера информационного взаимодействия из различных сфер жизнедеятельности, науки и техники.

В каждом из примеров укажите:

источник информации;
приемник информации;
среда (канал) передачи информации;
форма представления информации.

написать программу и блок схему

дана матрица
А= {-10 20 13
-22 11 -5
4 12 -8}
определить среднее арифметическое отрицательных и положительных элементов

не могу составить блок схему помогите пожалуйста ((

program pasha;
uses crt;
var a:integer;
begin
clrscr;
repeat
write('Введите 4х-значное число a=');
readln(a);
until(a>555)and(a<=5555);
writeln('Данное число читается одинаково справа налево и слева направо');
write((a div 1000=a mod 10)and(a div 100 mod 10=a div 10 mod 10));
readln
end.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.



Вы находитесь на странице вопроса "Срочно написать программу в паскале!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.