Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить алгоритм вычисления на ЭВМ значения

10-11 класс

функции:

NastyuXxXa 17 мая 2014 г., 15:34:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aleksandra11062001
17 мая 2014 г., 18:28:28 (10 лет назад)

const
  eps = 0.5e-5;
  x = 0.3;

var
  y1, y2, s, x2, px, n, k, sgn: real;

begin
  x2 := sqr(x);
  y1 := x;
  n := 3;
  px := x * x2;
  y2 := y1 + px / n;
  k := 2;
  sgn := -1;
  while abs(y2 - y1) > eps do
  begin
    px := px * x2;
    n := n + 2;
    k := k + 1;
    y1 := y2;
    y2 := y1 + sgn * (px / n);
    sgn := -sgn
  end;
  writeln('tg(x)=', y2, ' при ', k, ' членах суммы.')
end.

Тестовое решение:

tg(x)=0.308543055857143 при 5 членах суммы.


+ 0 -
пашка123456789
17 мая 2014 г., 19:42:46 (10 лет назад)

как вам удобнее, в задачнике написано надо итак и так,но я не буду двумя способами

+ 0 -
E170580
17 мая 2014 г., 22:00:10 (10 лет назад)

подскажите пожал, по какому принципу я выставляю балы за свои вопросы? есть ли правила?

+ 0 -
Doshaaidosha
17 мая 2014 г., 23:20:58 (10 лет назад)

Комментарий удален

+ 0 -
Akuligina02
18 мая 2014 г., 1:05:02 (10 лет назад)

ок

+ 0 -
Alleona
18 мая 2014 г., 1:47:59 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Паскаль:

Найти сумму и количество всех трехзначных чисел, кратных 100

ПОМОГИТЕ ПРОШУ.

Для целого числа k от 1 до 9 напечатать фразу «Мне k лет\года\год».
В делфи.

Помогите решить задачу в Кумире!

Пользователь вводит целое число. Каждую цифру в нем надо заменить по следующему принципу: "1" на "9", "2" на "8", "3" на "7" и т.д. Цифра "0" не меняется. Результат сохранить в отдельной переменной и вывести на экран. Например: ввод - "4569870", вывод - "6541230"

Помогите пожалуйста решить задание на Паскале по оператору перехода! Даны различные действительные числа a, b,

c, d.

Найти max (max(a, b), max(a, c), max(a, d)).Числа получить случайным
образом на интервале [-50..+50]

Читайте также

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

1) Проверить и исправить, если они есть, ошибки в буквосочетаниях: ча, ща, чу, щу, жи, ши. Написать программу, реализующую проверку словарного

диктанта. P.S. Длина слова типа string равна 255 символов 2) Составить алгоритм вычисления среднего арифметического значения температуры за месяц.

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.



Вы находитесь на странице вопроса "Составить алгоритм вычисления на ЭВМ значения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.