Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу вычисления выражения: max(x+y+z, xyz)+3 если x,y,z введены с клавиатуры. по паскалю.

10-11 класс

Aleksandra1545 21 янв. 2015 г., 7:59:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wedwinathe
21 янв. 2015 г., 10:26:24 (9 лет назад)

program xyz;
var max,x,y,z:integer;
begin
readln(x,y,z);
max:=x;
if ((max<y) and (y>z)) then max:=y
else if ((max<z) and (z>y)) then max:=z;
writeln(,max,'(',x,'+',y,'+',z,')=',max*(x+y+z));
end.

+ 0 -
12042000
21 янв. 2015 г., 13:15:35 (9 лет назад)

Уточни выражение под комментарием.

+ 0 -
Alloch
21 янв. 2015 г., 15:45:47 (9 лет назад)

Определить которое из них максимальное и умножить его на скобку x+y+z?

+ 0 -
Taya4
21 янв. 2015 г., 17:09:17 (9 лет назад)

да

Ответить

Другие вопросы из категории

ребяяяят!!помогите пожаааалуйста!! Составить и записать на одном из языков программирования. с клавиатуры вводятся три числа А,В,С.Если А-чётное

отрицательное,то вывести на экран значение суммы чисел А,В,С,иначе-значение произведения.

___________А 10. ЕГЭ.
Расскажите мне про эту программу(Pascal), что к чему здесь(где процедуры, функции, циклы и т.п.). Совсем не дружу с программированием((

var f,g: Text;
s,s1: string;
p: integer;
begin
Assign(f,'names.txt');
assign(g,'out.txt');
Reset(f);
rewrite(g);
while not Eof(f) do begin
Readln(f,s);
while s<>'' do begin
p := pos(',',s);
if p>0 then begin s1 := copy(S,1,p-1); s := copy(S,p+1,length(S)) end
else begin s1 := s; s := '' end;
p := pos(' ',s1);
if p>0 then write(g,copy(S1,p+1,Length(S1)),' ',copy(S1,1,p-1));
if (S<>'')and(S[1]=' ') then Delete(S,1,1);
if S<>'' then write(g,', ');
end;
writeln(g);
end;
Close(f);
Close(g);
end.

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.



Вы находитесь на странице вопроса "Составьте программу вычисления выражения: max(x+y+z, xyz)+3 если x,y,z введены с клавиатуры. по паскалю.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.