Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ

10-11 класс

Sardaryan96 11 янв. 2014 г., 19:27:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NasGomez
11 янв. 2014 г., 20:54:36 (10 лет назад)

var
slovo,simval:string;
i,k:integer;
begin
k:=0;
 write('Введите имя и фамилию ');
readln(slovo);
write('Введите символ ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
 writeln('Да, встречается ',k,' раз, на позиции ',i)else writeln('Нет');
end.

 

 

Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции... 

Ответить

Другие вопросы из категории

записать на языке алгебры логики следущее высказывание:

фирма С получит максимальную прибыль , если максимальную прибыль получит фирма В или не получит фирма А

От прямоугольника 324х141 отрезают квадраты со

стороной 141, пока это возможно. Затем вновь отрезают квадраты со стороной,
равной 324-2*141=42 и т.д. На какие квадраты и насколько будет разделен прямоугольник?
Решение программы в Pascal ABC

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую

длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.
паскаль!!!

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Читайте также

помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая: а) определяет, есть ли во

введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя....

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.