Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Ребят, помогите, пожалуйста, написать программу в pascal!!!

5-9 класс

Найти сумму первых двадцати натуральных чисел

Phyll 18 дек. 2014 г., 12:44:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Снежанa
18 дек. 2014 г., 15:32:31 (9 лет назад)

Program S1;
var
a,n,i,sum:integer;
begin 
write('Введите N:');
readln(n); 
sum:=0; 
 i:=0; 
repeat    if not(odd(a)) then      sum:=sum+a;   
i:=i+1;   
write('Введите ',i,'-е число:');
readln(a); 
until (i=0) or (i>=n); 
writeln(sum); 
readln;
end.
Вроде так, вместо n вводишь 20

Ответить

Другие вопросы из категории

ПОМОГИТЕ!!! 15 БАЛЛОВ

нужно составить из букв слова:
аскстеа
акжкин
секдиат
чевистерн

Помоги пожалуйста с решением( по программе Паскаль)

ввести три числа и найти наибольшее из них.

помогите пожалуйста кто хорошо разбирается в информатике

вставьте пропущенные слова
1) Сообщение ,,. , если оно выражено на языке , доступным для получателя .
2) Логическое познание Это ,,,,, (только одно слово)

3) Сообщение,,,,,,, является информативным для человека, если оно обладает такими характеристиками , как ,,,,,,,,,, и понятность ,
помогите пожалуйста если не трудно!!!!!!


какие сможете решите пожалуйста

Вычислить сумму чисел: S=К+(К+1)+(К+2)+(К+3)+…+(К+N); (N<N).
Вычислить среднее арифметическое чисел K,K+1,K+2,…,K+N; (K<N).
Вычислить произведение чисел: P=N*(N+1)*(N+2)*(N+3)*…*(N+R); (N<R).
Вычислить: P=1+(1*2)+(1*2*3)+(1*2*3*…*R).
Вычислить: P=1*(1+2)*(1+2+3)*(1+2+3+…+R).
Найти значения функции M=N2-N при N={2,4,6,…,T} (T-четное).
Найти значения функции X=Y2 *(Y2 -Y)/Y при Y={N*1,N*2,…,N*M} (N<M).

Умоляю помогите,мне нужно составить Алгоритм своего имени ,зовут меня Нурлан

Мне необходимо составить алгоритм каждой буквы : н,у,р,л,а,н
Примерно алгоритм выглядит вот так- Поднять перо. Сместиться в точку.Опустить перо.Сместиться на вектор.
Составьте хотя бы алгоритм буквы Н

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.

Помогите пожалуйста !!!!Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных

пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение.

Среди чисел a, b, c определить количество чисел кратных 3.

Помогите, пожалуйста, написать программу для Turbo Pascal или просто алгоритм.



Вы находитесь на странице вопроса "Ребят, помогите, пожалуйста, написать программу в pascal!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.