Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

30 пунктов тому кто решит третью задачу, паскаль. написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен

10-11 класс

вводиться случайным образом.

света771 21 авг. 2013 г., 6:56:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Миля12
21 авг. 2013 г., 9:55:37 (10 лет назад)

В массиве 10 элементов.
Случайным образом вводятся целые числа от 0 до 99.
x - ведённое с клавиатуры число.
i - цикловая переменная.

var
a : array [1..100] of integer;
x, i : integer;
begin
for i := 1 to 10 do
a [ i ] := random (100);
readln (x);
for i := 1 to 10 do
if a [ i ] := x then
writeln ('введённое с клавиатуры число находится в массиве');
end.

Минус данной программы: если введённое с клавиатуры число не находится в массиве, то программа ничего не выводит.

+ 0 -
Prayer
21 авг. 2013 г., 12:45:06 (10 лет назад)

немного подправила программу из предыдущего коментария

 

program proverka;

Ответить

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "30 пунктов тому кто решит третью задачу, паскаль. написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.