Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

PASKAL

5-9 класс

1) Написать программу с циклом.
Дана переменная "n", написать программу где все значения "n" будут суммироваться пока n не будет равно 1
2) Написать программу с циклом.
Дана переменная e, нужно выводить "e" в квадрат до тех пор пока "e" не будет равно 100
--------------
program test;
var..
begin

Павел9696 13 дек. 2013 г., 22:30:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Garecaa1
13 дек. 2013 г., 23:25:01 (10 лет назад)

var
    i, n, s: integer;

begin
    read(n);
    for i := n downto 1 do
        s := s + i;
    writeln(s);
end.

2)
var
    i, e: integer;

begin
    write('e = ');
    readln(e);
   
    if e > 100 then
        for i := e downto 100 do
            writeln(i * i)
    else
        for i := e to 100 do
            writeln(i * i);
end.


+ 0 -
Olgaspb95
14 дек. 2013 г., 0:08:04 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

выразить в байтах и битах 3кб.

Помогите пожалуйста)

имеется 4 арбуза различной массы. как пользуясь чашечными весами без гирь путём не более пяти взвешиваний расположить их в порядке возрастания массы?

опишите последовательность действий в виде нумерованного списка. пунктов должно быть пять

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

Читайте также

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Paskal abcТут задача, в которой нужноPaskal abc

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);


readln(x);


until y=x


writeln(‘Поздравляем,
вы ввели пароль верно’);


end.



Вы находитесь на странице вопроса "PASKAL", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.