Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны четыре целых числа. Найти среди них количество нечетных. В паскале

10-11 класс

Ислом 13 апр. 2013 г., 21:44:33 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nauryzbayyuriy
14 апр. 2013 г., 0:15:15 (11 лет назад)

program Necet;
var
Number: Byte;
NecetCol: Byte;
Numbers: array [1..4] of Integer;
begin
for Number:=1 to 4 do
begin
Write('Vvedite '+IntToStr(Number)+' chislo');
ReadLn(Numbers[Number]);
end;

NecetCol:=0;

for Number:=1 to 4 do
if Numbers[Number] mod 2 <> 0 then Inc(NecetCol);

WriteLn('Necetnix chisel: '+IntToStr(NecetCol));
end.










Ответить

Другие вопросы из категории

Помоги,пожалуйстааа))

Разработать, ввести в ЭВМ и отладить программу для
расчёта действительного расстояния между городами, если известно расстояние
между ними на карте и масштаб карты

построить алгоритм трех задач.
1.Для одновременного запуска сразу нескольких ожидающих потоков используется?

2. Для запуска только одного из нескольких ожидающих потоков используют?
3. Для исключения одновременного доступа к разделенным ресурсам несколькими потоками и без возможности многократной блокировки одним потоком используют?
4. Для одновременного доступа к разделяемому ресурсу заданного количества потоков используют?
5. Для исключения одновременного доступа к разделяемому ресурсу несколькими процессами используют с возможностью многократной блокировки?
Варианты ответов для пятого вопроса!!!
а) событие б) семафор в) мьютекс г) критическая секция д) нет правильно ответа
Варианты ответов для вопросов 1-4:
а) auto reset event b) semaphore c) mutex d) critical section i) manual reset event
Помогите пожалуйста!!!

Читайте также

Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное

среди них.Ничего кроме этого программа выводить не должна. При использовании системы Free Pascal для представления целых чисел используйте тип LongInt. Надо сделать в Pascal

Как это сделать в Excel?

Ввести с клавиатуры 3 числа, найти среди них
наименьшее. Предусмотреть выводы данных на дисплей.

Задание. Составьте блок схему алгоритма решения задачи и программу на языке Turbo Pascal c использованием условного оператора.

Даны три целых числа.Найти кол-во положительных чисел в исходном наборе.



Вы находитесь на странице вопроса "Даны четыре целых числа. Найти среди них количество нечетных. В паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.