Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ввести с клавиатуры натуральное число N. И с помощью цикла вычислить: 2^N , N!

10-11 класс

Константин180543 27 февр. 2014 г., 21:39:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Taraba98
27 февр. 2014 г., 23:41:13 (10 лет назад)

Program P;
Var
    I, N : Integer;
    S : Integer;
Begin
    S := 1;

    Write('Enter N ');
    ReadLn(N);

    for I:=1 to N do
        S := S * 2;

    WriteLn(S);

    ReadLn;
End.

+ 0 -
Сусликоежка
28 февр. 2014 г., 2:33:05 (10 лет назад)

Program pr;
uses crt;
Var n, i:integer;
    s:real;
Begin
s:=1;
Writeln('Введите n');
readln(n);
For i:=1 to n do
Begin
s:=s*2;
Writeln(s);
end;
readln;
end.

Ответить

Другие вопросы из категории

1. Какие значения будет принимать величина- счетчик при выполнении следующего цикла: от p=7 до -7 шаг

-1.

2. Вычислить все квадраты двухзначных чисел, не превышающих 100

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Читайте также

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)



Вы находитесь на странице вопроса "Ввести с клавиатуры натуральное число N. И с помощью цикла вычислить: 2^N , N!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.