Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

"даны вещественные числа t , x, y, z. поменять их значения местами "по кругу" записав на место t значения x , на место x значение y, на место y значение

5-9 класс

z, на место z значение t"

Нюта26 30 мая 2013 г., 5:49:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Neff1
30 мая 2013 г., 7:21:56 (10 лет назад)

var t, x, y, z, m, n:real;
begin
 writeln ('Vvedite t, x, y, z');
 readln(t, x, y, z);
 m:=z;
 z:=t;
 n:=y;
 y:=m;
 m:=x;
 x:=n;
 t:=m;
writeln ('t = ', t);
writeln ('x = ', x);
writeln ('y = ', y);
writeln ('z = ', z);
end.



Ответить

Другие вопросы из категории

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Постройте алгоритм и составьте программу, по которой будет реализован следующий сценарий: компьютер запрашивает номер дня недели, после ввода компьютер

сообщает название этого дня. Например, если ввели 1, то выведется фраза «Это понедельник» и т. д.

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время

прибытия самолета в аэропорт назначения в виде «чч:мм» Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде «чч:мм

Читайте также

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

1.Дано трехзначное число. а)Определите, входят ли в него цифры 4 и 7. б)Определите, входят ли в него одновременно цифры 4 и 7. 2. Даны

четыре целых числа. Вывести на экран минимальное из них.

3.Даны три вещественных числа a, b и с - коэффициенты уравнения ax^2+bx+c. Найдите решение этого уравнения или сообщите, что решения не существует.



Вы находитесь на странице вопроса ""даны вещественные числа t , x, y, z. поменять их значения местами "по кругу" записав на место t значения x , на место x значение y, на место y значение", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.