Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите с Циклами

10-11 класс

Вот фото

вапуреп 17 июня 2013 г., 1:45:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xlebic2008
17 июня 2013 г., 3:21:33 (10 лет назад)

var
  S: real;
  i, k, l: integer;
begin
  S := 1;
  for i := 1 to 12 do
  begin
    k := 1; l := 1;
    while (k <= i) do
    begin
      l := l * 3;
      k := k + 1;
    end;
    S := S + 1 / l;
  end;
  writeln(S);
end.
-------------
function 

+ 0 -
Danpp115
17 июня 2013 г., 4:35:44 (10 лет назад)

в паскале

+ 0 -
Vanya229
17 июня 2013 г., 6:58:26 (10 лет назад)

Комментарий удален

+ 0 -
Snils171
17 июня 2013 г., 8:59:46 (10 лет назад)

Паскаль

Ответить

Другие вопросы из категории

1) Составить фразу "волчий аппетит" из слов "аптека", "ствол", "чайник".

2) Вывести на экран первую букву третьего слова данного текста. Если нет третьего слова, то вывести сообщение "ошибка".

помогите пожалуйста решить задачи и закодировать их в программе visual foxpro 9.0!!!!!

1) определить время через которое встретятся два тела равноускоренно движущиеся навстречу друг другу,если известны их начальные скорости ускорения и начальное расстояние между ними.
2)даны целые числа m,n (0<m<или равно12,0<или равно n<60),указывающий момент времени:" m часов, n минут" .Определить наименьшеевремя(число полных минут),которое должно пройти до того момента когда часовая и минутная стрелки на циферблате совпадут.

ну оооочень нужно!!!!!!

Составьте программу, которая:

в) заменяет в формуле, заданной с клавиатуры, круглые скобки на квадратные.

Читайте также

Ребята,помогите добавить цикл.который будет генерировать случайные числа,с помощью команды srand.

Эта программа определяет,возрастающая или убывающая последовательность чисел.

если возрастает,например 1234(1 < 2 < 3 <4 )-то пишет 1
если убывает 321 или 231(3 < 2 < 1)-ложь,пишет ноль
если 111(1 < 1 < 1)ложь,тк строгая возрастающая последовательность,пишет ноль


#include <iostream>
int main()
{
int n;
bool flag = true;
std::cin >> n;
while(n != 0)
{
while (n >= 10)
{
if(n / 10 % 10 >= n % 10)
flag = false;
n = n / 10;
}
std::cout << flag << std::endl;
flag = true;
std::cin >> n;
}
}

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3



Вы находитесь на странице вопроса "Помогите с Циклами", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.